<- Previous Log Select Different Log Next Log ->  
Log from 2018-09-23:
[00:52:36] *** Joins: physkets (~physkets@unaffiliated/physkets)
[01:27:24] <physkets> Hey!
[01:27:56] <physkets> The build fails for me with boost v1.68
[01:28:11] <physkets>     /usr/bin/ld: tron/armagetronad_main-gFloor.o: undefined reference to symbol '_ZN5boost6system6detail20generic_category_ncxEv'
[01:28:24] <physkets>     /usr/bin/ld: /usr/lib/libboost_system.so.1.68.0: error adding symbols: DSO missing from command line
[01:28:36] <physkets>     collect2: error: ld returned 1 exit status
[01:28:45] <physkets> Anybody know why?
[05:49:15] <ljrbot> New news from bzr: [0.4-armagetronad-work] r1623 Added forgotten break statement....
[06:49:29] <ljrbot> New news from bzr: [0.4-armagetronad-work] r1624 isblank() is in a standard c++ header, so we can now rely on...
[14:53:46] *** Quits: physkets (~physkets@unaffiliated/physkets) (Quit: physkets)
[15:32:06] <Z-Man> physkets: that sounds like the kind of error you get when your boost libs do not match the headers.
[15:32:19] <Z-Man> It could also be a wrong library link order, can you post your linker line?
[15:34:12] <Z-Man> One thing to try there immediately: in configure.ac, the boost_thread lib is included using
[15:34:21] <Z-Man> LIBS="-lboost_thread ${LIBS}"
[15:34:45] <Z-Man> which puts it BEFORE -lboost_system in the final command line. What may work better is
[15:34:57] <Z-Man> LIBS="${LIBS} -lboost_thread"
[15:37:28] <Z-Man> Though reading through this https://stackoverflow.com/questions/19901934/strange-linking-error-dso-missing-from-command-line , the thing we have should be correct.
[16:09:51] <Z-Man> If Thedarkb-T60 turns up again, tell him to remove the SERVER_IP line from his config. It's probably wrong, it does not show up in the master logs. And the item is really only ever useful on servers that have multiple IP addresses.
[16:21:40] <ljrbot> New news from bzr: [0.4-armagetronad-work] r1625 Fixed warnings about fallthrough in switch statements (one o...
[16:33:06] <Z-Man> Maybe LIBS=" -lboost_thread ${LIBS} -lboost_thread" if there is a cyclic dependency in boost_sys and boost_thread? doubt it, though. boost_sys should definitely be standalone.
[18:05:26] *** Quits: Z-Man (~Z-Man@p5B326803.dip0.t-ipconnect.de) (Ping timeout: 260 seconds)
[18:05:48] *** Joins: Z-Man (~Z-Man@p4FE3E408.dip0.t-ipconnect.de)
[21:42:44] *** Joins: Z-Man- (~Z-Man@p5B326298.dip0.t-ipconnect.de)
[21:42:44] *** Z-Man is now known as Guest30894
[21:42:44] *** Quits: Guest30894 (~Z-Man@p4FE3E408.dip0.t-ipconnect.de) (Killed (card.freenode.net (Nickname regained by services)))
[21:42:44] *** Z-Man- is now known as Z-Man

View entire month
DISCLAIMER: These logs of public chat may contain some content which may not be appropriate for all audiences. Use at your own risk.
Logs from 2006-2009 pulled from wrtlprnft
Format changes at: 2015-08-25, 2017-02-20, and 2020-03-23. Times (2015 and later) should be Eastern.


 
 
 ArmaNelgTron.tk
 © NelgTron 2014-2021. Made for . [About this site] [Credits]